No processed documents from Semantria
Incident Report for Semantria
Resolved
All customer accounts should be resolved.
Posted 11 months ago. Jan 04, 2018 - 11:39 EST
Identified
We have identified the issue and are working to resolve.
Posted 11 months ago. Jan 04, 2018 - 08:40 EST
Investigating
Several clients are able to submit documents to Semantria but do not receive responses. We are investigating.
Posted 11 months ago. Jan 04, 2018 - 08:19 EST